Please let me know if you find bugs!


#1

Dear wonderful people. Please let me know if you find any bugs in this stuff. This is version one so there may be some small hiccups. I will try my mightiest to tackle them pronto.

cheers all,
Walker


#2

Walker,

My Excel can’t open any of the tools XL files. Get error, file damaged. My Excel seems to open other XL files.
In particular was trying to open the PZ curve adjustment.

Mark

PIEZOGRAPHY_CURVE_ADJUSTMENT.xlsb (103 KB)


#3

Tested my excel 2008: it does open and save other .xlsb files. These throw up the above error.


#4

Oh no!

 

I will fix in just a bit. This will be v 1.2

 

sorry for the delay,

Walker


#5

I just downloaded the attachment above and it works fine on three computers and two versions of excel (v2008 and v2016).

 

What version are you using?

 

best,

Walker


#6

ps: I added this .zip file archive of all files in PiezoDN v1.2 (downloadable now).

Here’s the zip archive directly. Let me know if these work.

 


#7

Hi Walker,

Still the same errors here. My Excel 2008 for Mac is version 12.0 (071130). It might miss the neccesary xml tools or they don’t work in El Capitan 10.11.5. In Library/Application Support/Microsoft/Office Converter Support there are both non macos 10.11 supported frameworks like ‘Open XML for Excel’ as supported ones like ‘Open XML for Excel.framework’.

What OS version do you use?

best,

Kees


#8

Walker, just tried your new archive and no dice. I too am using an old excel 2008 version. would think files created on newer software would be backwards compatible. Never had problem getting files from several sources that were probably created on newer software than mine.


#9

Sorry. Just looked back at my install history. I have 2011 and 2016 (NOT 2008). It might very well not work in 2008 as it uses some pretty advanced Visual Basic code + functions that I think were published later than 2008.

That said, there is a Numbers tool in there for the very basic SMOOTHER function required to linearize and build ICCs. The custom tuner function is excel only. You may have to go subscription (I’ve tried to avoid it until now. oy.)

Best,

Walker


#10

walker, perhaps if you were to indicate your dev tool chain, it would help those attempting to read the distribution. apparently some of the tool requires the use of VBA Excel…

richard


#11

hi,

I can confirm that the files will open in excel 2011. So Office 2008 is not supported. Tested and written on a macbook pro late 2008. :wink:

kees


#12

I updated the requirements documentation. This was an oversight on my part.

This will not work with anything other than 2011 or newer as there are some functions in there that only work with that version and newer. Confirmed.


#13

Hey Walker,

I don’t think this is a bug, in fact my guess is that it may not matter, but I have noticed that on the CGATS sheet of the Smoother tool if I click Command-A to select the data it does not include the top 5 lines. I haven’t tried it this way, I have included those lines in my .txt file, but I’m wondering if this means they are unnecessary.

On a related note, I see that you are advising that we must make the .txt file via a new spreadsheet saved as tab delimited text if using Excel, but if working from Numbers it is ok to simply make a new text file in TextEdit, which is what I have been doing. This seemed illogical to me, why would it work to make the text file with TextEdit with identical data from Numbers but not from Excel, so I tested it. Using the CGATS data from the Excel Smoother, I made one text file with TextEdit and another with Excel, then made a linearized curve with each. The resulting negatives are identical in every way.

My last linearization of Platine was perfect on the first try. And creating an icc brought the tones down exactly as you said it would, though I still think it makes it too dark, at least for my taste. So I will probably end up not using icc profiles, printing with No Color Management, and simply making a unique curve for each paper and/or chemistry combination that I use.

I started calibrating Hakkinshi, which is quite different from Platine, HPtR, etc., last night and should have it linearized by tomorrow. Next up will be Gampi Torinoko.

Thank you for this truly amazing tool.

Keith


#14

When copying from excel, it sometimes adds cell-data when pasting into TextEdit. That is because both Excel and TextEdit are capable of copying/pasting RTF format.

So to keep bugs from happing I advise people to simply copy to a new excel spreadsheet and save this as a tab delim. txt file.

Not sure about the select all (command A). This also doesn’t generally work with spreadsheets as selects un-wanted cells.

I’m super excited that you’re finding this a very useful tool! ps: the 3880 curve in there should work on your 4800. Have still been so swamped at work to validate it.

best,

Walker

 


#15

Here’s something else peculiar that I just noticed. I won’t be able to verify it until the print is dry though. On my linearized 129-step print on Hakkinshi there appeared to be no change from the unlinearized print at the moment the developer hit it. This paper nearly disappears when wet so it is impossible to make any judgements until dry. But I thought maybe I had used the wrong curve, or used the wrong text file to make the linearized curve. Checked the last used settings in Print Tool and that was correct, so I thought to look at the .quads in TextEdit. The linearized Hakkinshi Curve is definitely different from the Master, but when I compared it to the Platine curve I found it to be 100% identical. Plots of the smoothed results of the first test are roughly similar but not identical, so it seems unlikely that the linearized curves would be identical. The text files made from the CGATS sheet are definitely not the same. Thinking that I may have used the wrong text file to do the linearization, I did it again taking extra care that I had the right files. The resulting .quad is exactly the same. This may be just an academic exercise, but I thought it was interesting. The print will be dry in a couple hours and I’ll post the results later.

I am not suggesting that this is a bug, so this comment maybe should be under another heading.


#16

How curious. The linearization did a nice job on the highlights, but pretty much left the shadows intact, the midtones tapering between the two. I am running a second linearization to see if that helps. An icc profile might do it too, but my experience with iccs so far is that they bring the shadows down too far for my taste. So I am trying a second iteration of linearization first.

My last round of linearization with Platine, using the official release version of the PiezoDN, produced a nearly perfect linearization on the first attempt, and deeper shadows with the icc as expected.

I didn’t expect Hakkinshi to be so easy to profile due to it’s translucence and fibrousness. It’s sort of a moving target. I’m trying to help a friend who is printing on a similar washi called Shikibu Gampi but having trouble with highlight rendering using a scanner to read the target print values. She is not using PiezoDN yet, but is interested. I think if I can make a good profile for the Hakkinshi I’ll be able to do the same for other tricky papers.

Walker, I maybe should have started a new topic for these last 2 posts. Sorry about that. Please feel free to move them if you want to.


#17

I spent the last week at Don Messec’s Making Art Safely Platinum / Palladium / PiezoDN workshop. I carried my 1430 printer with me. I bought, downloaded, and installed PiezoDN on my Macbook Pro. Everything worked fine with my printer and my laptop. Unfortunately I had clogged nozzle in my printer so I moved my laptop to Don’s 1430 printer, USB connected, and tried to print a digital negative from there. The short version of a long story is that no matter what we did we could not get my laptop to print a digital negative to Don’s printer using QTR and PiezoDN. When my printer problem cleared up I had no issues with printing with QTR and PiezoDN. The installer has no tolerance for two printers…

Fast forward to this morning. I put my printer in it’s usual location, fixed a broken wifi connection problem, flushed, cleaned nozzles, etc from my Mac Pro with no issues. I downloaded and installed PiezoDN to the Mac Pro. This is my primary machine. I only use the laptop when I travel. I tried to install the PiezoDN “printers” (4900 and 1430) and both installs failed ,numerous times. Both times I connected from the printer to the computer with a USB able.

I think it’s because I’ve got both of them set up with Piezography and DN “sees” that.

On another note, it is not practical for me to connect my MacPro to either printer with USB normally. I have to use the network connectivity features of both printers to be able to use them. Surely this stuff hasn’t been downgraded to USB only for normal use?

I need a workaround. I’ve got a lot of money tied up in a dig neg printing system and I’m dead in water right now.


#18

Maybe this warning has something to do with it"

 

<p class="p1"><span class="s1">Last login: Sun Jul 24 13:44:38 on ttys000</span></p> <p class="p1"><span class="s1">/Applications/Piezography/Curves/4900-PiezoDN/Install4900-PiezoDN.command ; exit;</span></p> <p class="p1"><span class="s1">WLIS-Mac-Pro:~ mikell$ /Applications/Piezography/Curves/4900-PiezoDN/Install4900-PiezoDN.command ; exit;</span></p> <p class="p2"></p> <p class="p1"><span class="s1">*********************************************************************</span></p> <p class="p2"></p> <p class="p1"><span class="s1">ALERT! **** Printer Description File (PPD) not found for printer 4900</span></p> <p class="p2"></p> <p class="p1"><span class="s1">First try re-installing QTR via the Install-QTR-###.pkg file</span></p> <p class="p2"></p> <p class="p1"><span class="s1">*********************************************************************</span></p> <p class="p2"></p> <p class="p1"><span class="s1">logout</span></p> <p class="p1"><span class="s1">Saving session...</span></p> <p class="p1"><span class="s1">...copying shared history...</span></p> <p class="p1"><span class="s1">...saving history...truncating history files...</span></p>
<p class="p1"><span class="s1">...completed.</span></p>

#19

fyi, the alternative way to install is to simply click the install.command scripts in each respective curve folder just like normal QTR.

 

regards,

Walker


#20

I tried that. I already had the 1430 and my 4900 installed in QTR. Piezo DN install scripts wouldn’t install until after I reinstalled QTR and Print Tool. I’m not sure which one fixed the problem but one of them definitely made the install scripts work. I saw the same problem when I was in Don’s studio last week. I already had my 1430 installed and when I tried to add Don’s printer, because mine was clogged, the install failed.