129STEP PiezoDN Linearization Smoother Tool


#1

I read my 129 Spyder Step and saved the txt file (per Kieth’s blog), but when I try to paste the data into the 129SETP_PIEZODN_CGATS_SMOOTHER.xlsb tool, I get a message saying the tool is read-only, but when I try to unprotect the workbook it requires a password. Where can I get a read-write version?


#2

Make sure you are only selecting 129 rows of data, and columns (LAB).

Alternatively you can open the exported cgats file in excel and select only the 129 L* values and “paste special, text only” starting at the first L* number in the smoother tool.

 

best,

Walker


#3

Tried that, still get the message that the the workbook is read only.


#4

I used Numbers and that seems to work. The values are in fact pasted even though I get a read-write message warning. Now for the next step in the process…

Thanks,
Robert


#5

Please .zip upload the original measurement file (or screenshot of the smoother tool) so I can see what’s going on.

The Excel version is much more up to date and would be ideal to use . . .

 

-W


#6

Attached is the screen shot when I try to paste the data into the smoother tool. There’s not much to see except for the read-only message. As you can see I’m pasting in cell B/8, but even if I try to manually input a number in any cell I get the same message.

[attachment file=“Screen Shot 2018-01-09 at 10.41.22 AM.png”]

[attachment file=29107]


#7

You are pasting into the “CGATS” sheet. It is locked for this very reason!

You need to go to the CURVE sheet and paste your values. The CGATS sheet is the smoothed values.

best,

Walker

 


#8

Walker, sorry, the CURVE tab was “hidden” so I couldn’t see it. Once I exposed all the sheets, there it was. HOWEVER, when I try and paste into the CURVE tab, cell F4, I get the same read-only message. If I manually put a number in a cell, it accepts it on this tab, just not the paste function. I opened the Excel file in LibreOffice and got the same message. Then, I pasted the values into a new Excel workbook, and they pasted there just fine, so I tried copying them from the new Excel workbook into the CURVE tab, and got the read-only message. I tried paste, paste/special/values… not possible.

Thanks…
Robert

[attachment file=29111]


#9

This is because you have selected more than 129 rows of data or more than 3 columns.

-W


#10

You need to have F4 thru H132 selected, then paste. I just tried it to verify. Other ways such as selecting just F4 result in what you described. I can see from your screenshot that you don’t actually have any of the green cells selected. When you select them the green gets darker and the entire range is outlined in a thicker line. Click on cell F4, scroll down to the end of the green cells, hold shift and click cell H132. Then paste your data.

By the way, I do see that this is different than what I wrote in the article. I’m also sure that it worked as I described in the article at that time. Maybe there has been some change in Excel since then. I don’t know. But I had noticed this change in copy/paste behavior elsewhere.

 


#11

Kieth, that was the correct solution. Highlighting the entire section and pasting worked as expected. Normally when pasting in Excel I simply start at the upper left cel and paste, obviously that does not work in this situation. Attached is a screen shot of the result. It was my first attempt using my new Spyder and I’m not sure my scanning method was smooth/accurate as it could be. I think I need to do it again for another txt file of data.

[attachment file=29122]


#12

Here’s my next attempt.

[attachment file=29126]


#13

I thought my wobbles were bad! Be sure the Spyder’s head :slight_smile: is firmly on the paper before pushing the read button. Also, the graph should be showing a trend-line (I think that’s the right term) that describes the smoothed values. (See attachment.)

Could you make a scan or photo of the target print and post it here? I’d like to see if there is any other reason for those extreme wobbles.


#14

You need to do this again most likely. Also, re-install PiezoDN completely so you have a new fresh CGATS smoother tool because you have lost your smoothed CGATS data entirely. I thought I had locked this down enough so that it doesn’t easily get killed, but I must have let something loose.

Please also post a photo of your printed paper so we can see if it has problem.

 

best,

Walker

 


#15

Here is my step print. The first highlight box showing the first hints of grey is box #3. My DN is printed using the Master.quad, and chemicals are Pd+equal drops of FO, Developer is P.O. Exposure time is 5 minutes on Arches Platine.

[attachment file=29134]


#16

This looks pretty good. You don’t see tone until step 3, but the Spyder does! Check out the L* values in the first few steps. I do see a problem though. See the little check-mark shaped segment at the bottom left of the graph? Your last reading MUST be the darkest of the series. This could be a read error, or it could mean you are a bit overexposed. Redo the readings and see if you get the same result in the blacks. If so you’ll need to cut back your exposure time a little. But make sure it’s not a read error first. It’s not uncommon, and if it’s only the last 2 readings (steps 128 and 129) all you need to do is make sure 129 is lowest. It’s ok to fudge it manually. But if it’s more than those 2 steps you probably need to reduce the exposure time by maybe 10%.

 


#17

I was a careful and deliberate as possible. Any better? Do I still need to completely reinstall the Piezo DN package as Walker said in an earlier response?

Thanks…Robert

[attachment file=29138]


#18

when I look at the CGAT tab there is no data being populated from the Curve tab.


#19

Robert. Please re-install PiezoDN so you can re-fresh your CGATS smoother tool.

 

best,

Walker


#20

Walker, I just reinstalled the PiezoDN package, then pasted the data into the Curve tab, and the CGATS tab is still not populated. I tried saving a copy of the file to my desktop to see if that mattered, and it did not.