Smoother tool using Numbers


#1

Does the Smoother tool using Numbers work?

Im having trouble generating a -lin file but I’m wonder if it because I cannot save the CGATS data as a text delimited file when saving from Numbers. So I either drag the plain saved file or rename it .txt (same error happens) and drag both the number/txt file and quad file across to the QTR-Linearize-Quad droplet and in generates a -out file which has the error message at the bottom - “The Lab values are not in order”. Cannot be linearized.

I have attached a snip of numbers smoother file hoping that in may help in show my error and the file txt file and the -out txt file …

 

Quad-error-1.tiff (206 KB)

Kalltype1-out.txt (80 KB)

Kalltype1.txt (221 KB)

Kalltype1-1.txt (221 KB)


#2

A couple of quick things I see:

  1. There is no LAB data at all in the -out.txt file.

  2. I can’t open the other txt files.

  3. Copy the already selected data from the CGATS page into a txt file. No need to worry about tab delimited.

  4. Are you sure you are copying the data from the CGATS page? You posted an image of the Curves page which looks fine. I do see a reversal but the Smoother fixes that in the data on the CGATS page.

[attachment file=1528]


#3

Hi Keith,

Thank for trying to help.

The -out file is generated by PiezeDN so not really sure while the data is like that.

The two txt files (I tried twice) are Numbers files but when I drag it into the forum it gets convert and then messed up and not readable. I have attach a snip of the top of the GCAT file as copied into a new iOS Number file. At this point you would save the file into the right curves directory then select both file and quad to drag to QTR-lin-quad droplet but if I drag the raw iOS numbers file and the quad nothing happens, if I rename the numbers file to kallitype.txt them the -out file is generated as shown.

Note the shown file (jpg) follows the same format all the way to the end then there is one extra line at bottom which say “end of file”

Should i be grabbing all the data like shown or just the LAB vales only.

Come Monday hopefully my work computer will be working again and I can use Excel.


#4

Save the CGATS as a txt file in TextEdit NOT Numbers. That is the problem. You can’t save Numbers files as a text file and changing the extension doesn’t change that. Open a new file in TextEdit and paste it there, then save that.

Yes, all the CGATS data from A1 to D137.


#5

Hi Keith,

Thats the conclusion I was getting but in numbers I cannot see anyway to save as a txt file, so I download a free mac text editor (text wrangler) and pasted the information into that. Then when I ran the QTR-lin-quad everything worked fine. See attached -out file.

Thanks for help.

shane

kallitype-text-out.txt (11.5 KB)


#6

Footnote - I didn’t realise TextEdit as a program existed until just then (Windows XP user until 3 month ago…)


#7

Right, you can’t save a text file directly in Numbers. That’s why I said to copy and paste it into TextEdit. Now I see why that didn’t make sense to you at first. :wink:

Glad you figured it out.


#8

Thanks Keith!