Problem with Print Tool and PiezoDN


#1

I have been using PiezoDN and Print Tool on my iMac with El Capitan and Epson 9800 for some time. Today I was trying to print a PiezoDN file. When I opened the dialogue box for my Epson 9800 with the PiezoDN driver, the QTR option under the Layout box was gone.

Here is the information from the QTR DiagnosticScript.command:

E [15/Dec/2016:16:24:43 -0500] PPD file for Quad9800-PiezoDN cannot be loaded.
E [15/Dec/2016:16:24:43 -0500] Illegal option keyword string on line 310 of /private/etc/cups/ppd/Quad9800-PiezoDN.ppd.
E [15/Dec/2016:16:45:00 -0500] PPD file for Quad9800-PiezoDN cannot be loaded.
E [15/Dec/2016:16:45:00 -0500] Illegal option keyword string on line 310 of /private/etc/cups/ppd/Quad9800-PiezoDN.ppd.
E [15/Dec/2016:16:46:56 -0500] PPD file for Quad9800-PiezoDN cannot be loaded.
E [15/Dec/2016:16:46:56 -0500] Illegal option keyword string on line 310 of /private/etc/cups/ppd/Quad9800-PiezoDN.ppd.

In my iMac preferences, the Quad9800-PiezoDN driver still shows up.

I had just deleted some test .quad files and in the process a message flashed up about a printer proxy being deleted.

I reinstalled the Piezography Community Edition.

Apparently the PPD is not operative. What can I do to get PiezoDN and Print Tool to work?

Tim McCoy


#2

Walker will probably know exactly what’s going on here, but I think he is traveling so I’ll try to help. I’ve never seen this myself, but I suspect that the deleted printer proxy has something to do with it. I don’t think Piezography Community Edition has anything to do with this, but it might be a good idea to reinstall PiezoDN.

You probably have installed both Piezography and PiezoDN, and have 9800-K7 and 9800-PiezoDN in your printer list.


#3

I’m experiencing exactly the same problem with a 3880 (with the older ink setup), on an iMac with OSX Mavericks 10.9.5.:

  • QTR option is gone
  • I deleted some test .quad files
  • the Quad3880-K7 does give the QTR-option
I did not notice a message about a printer proxy when deleting the .quads.

I reinstalled both QuadtoneRIP and PrintTool. I even restarted the iMac.

I reinstalled the curves of 3880-PiezoDN and something strange happens: it says it installed curves that are deleted, i.e. the test .quads. These curves cannot be seen in the folder with the curves. See screenshot: the curves “test-curve” and “PiezoDN-X8-…_20161219” cannot be seen in the folder, but show up in the terminal screen

[attachment file=26114]

I don’t know if it is important: I am not able to save .quads directly into the 3880-PiezoDN folder. I can only paste files in the folder.

Please help!


#4

The one .quad with tons of text in it has too long of a name! This screws up QTR. It’s a bug.

You need to delete it and delete it again inside of a different folder, then re-install QTR.

Here’s instructions on how to delete the offending curve.

best,

Walker


#5

I knew Walker would spot it right away! Sorry I skimmed right over that. And I forgot that I had this issue once before too. The limit is somewhere between 38 and 41 characters if I remember right. The offending filename here is 45 characters. The one that caused my problem was 42 characters. I removed a segment cutting it down to 38. That worked.

Of course that doesn’t explain why “test-curve” didn’t install.

 


#6

Thank you very much, Walker! I will try to follow your instructions tomorrow (it’s already evening in Europe and I expect some friends to arrive any minute now for dinner :wink: ).

And thank you Keith also, for your support!


#7

Problem solved! Thanks, Walker

Cheers, Wilco