PiezoDN smoother tool error messages on a PC


#1

Why do these errors happen using the smoother tool on a PC? Better yet, how do I fix them?

The first error happens when I try to paste Lab values. (It’s not from attempting to paste too many cells). It usually happens, but not always, when I attempt to paste a second set of Lab values over the first set I had pasted. (trying to compare two sets of data).
The second pair of error messages occur when the smoother tool spreadsheet has been open for a while, and I may not even be attempting to do anything.
Both have happened numerous times.

PiezoDN-Smoother-Tool-error.docx (29.4 KB)


#2

Can you please describe what errors happen exactly?

-Walker


#3

Are you able to see the errors in the attached Word document?


#4

I think the first one means that you are trying to paste something to the wrong place. It would be helpful to see exactly what you are trying to paste and where.

I agree that it is useful to be able to compare data sets - it’s something I’ve been doing for a long time with my own spreadsheets. The PiezoDN ones are locked by necessity, but there is no reason you can’t make your own and plot whatever you want to on it. That’s where I get the graphs that I often post here. Usually I plot the data from the L column of the CGATS sheet. It’s useful to see the progression of the linearization process and variations on one graph.

Do you know how to do that in Excel?


#5

I’m pasting the data as per the instructions in the documentation. I don’t believe that I’m pasting the data in the wrong place or that I’m pasting too many cells. I never get the error (“The cell or chart that you are trying to change is protected…”) the first time I paste, and I do get the results. It’s always after that, and I’m pasting the data in the same manner.

I was trying to replicate the problem. I was able to get the error to appear numerous times, but can’t pinpoint the exact scenario, as the error popped up with different sequences.

I never get the error on the first time I do a paste. I’ve seen the error on pasting the second set of data, but not always. Sometimes the error will come with the third time I paste. I’ve tried having different number of files open, but I can’t pinpoint the exact sequence(s) that causes it.

I’m using a PC. Keith, are you using a MAC, and have you ever seen the problem?


#6

I’m on a Mac, though I doubt there are significant differences in Excel that would account for this. I want to try to replicate the problem using your data file. That is the only way I know to try to help. If you would like me to try this, please attach the text file from your measurement software.


#7

I doubt if it’s the file. It will happen to any of them.

I’ve attached 3 .txt files, along with the Excel smoother file I’m using. (ignore the data. it’s not the best)

I open all 3 .txt files (with Excel). I open the Excel smoother file. I copy/paste the first set in. No problem. Then I copy another set from a second file. When I try to paste, I get the error message.

Next scenario. I open 2 of the data files, then the smoother, and try the same as above. Same thing.

If, instead I open just 1 of them, then the smoother, copy/paste, open a second file, then copy/paste. No error. But when I open a third file and try a copy/paste, I get the error.

Now, in all cases, if I click the UNDO arrow, then try to paste, it will work and no error message is generated. Which tells me it’s not the data.

 

PiezoDN-129step-i1Pro2-HahnPtPd3min-12102016.txt (7.05 KB)

PiezoDN-129step-i1Pro2-HahnPtPd3min-12112016.txt (7.05 KB)

PiezoDN-129step-i1Pro2-HahnPtPd4min-12072016.txt (7.05 KB)

129STEP_PIEZODN_CGATS_SMOOTHER.xlsb (97.3 KB)


#8

I just copied and pasted all 3 data sets with no problem at all. To be more specific, I copied/pasted columns D, E, and F (the L, A, and B columns). I even went back and forth among them several times. I have no idea why you have 3 extra columns. Is that just an X-rite or ColorPort thing? I use SpyderPrint which gives me LAB values in tab delimited text format. I don’t have to open the text files in Excel in order to select the correct part of the data.

So my best guess is that your Excel may be corrupted. Have you tried updating or reinstalling Excel?


#9

Three extra columns? It’s an i1Pro thing…(RGB) and it’s not an issue.

I’ve tried the data on another computer and get the same results, so my excel is not corrupt. The next thing will be to find another version of excel and give it a try.


#10

When I open your text files, there are 6 columns of data. The only ones you should be copy/pasting into the Smoother are the 4th, 5th, and 6th which are the L, A, and B values. If you are trying to copy/paste more than that, it definitely would be an issue. Do you not see the other columns?

A while back Walker did identify a problem with older versions of Excel. Maybe that has something to do with it. Is your current?


#11

Yes I do see the six columns of data, and yes I know that it’s the LAB data that we are working with. The other three columns of data are not an issue because I’m not using them.

What problem did Walker identify with older versions of excel? And what versions are considered older?


#12

Ok. Sorry for harping on it, but you weren’t answering my question directly, so I wasn’t sure I was asking it clearly. All clear now.

Walker will have to answer that himself. I don’t remember the details other than that there is some programing language stuff going on that earlier versions than ??? did not support. I didn’t have Excel at all at the time and Numbers didn’t support it either so I had to bite the bullet.

Here’s another thought, not likely but might be worth a try. When you copy/paste from a text file there is no formatting or anything else to be concerned about. But when you copy/paste from one spreadsheet to another there could be. So instead of pasting by keyboard command+C (or the Windows equivalent), or some other simple paste command, right-click and choose Paste Special, then select Values and click OK. This way you can be sure that no extraneous formatting or other stuff is being pasted. The exact Windows procedure may differ.


#13

Copy only the Lab_L column numbers.

 

You are copying more than 3 columns of data and this is hitting up against locked column in the spreadsheet.

 

Best,

Walker

 


#14

Ok. Just to be clear, I am only copying 3 columns of data, which are the L, a, and b values.

As I mentioned, I am able to get results. The issue is that when I try to copy/paste another set of data (just to compare - I use the undo/redo button to go back and forth), I will get the error sometimes.

I can hit the undo button and paste the second set of data, so I know it’s not the data. It’s just that I can’t go back and forth to do a compare between two or more sets of data.

It appears it may be an issue with my version of Excel. So, which versions of Excel are considered older? And what issues would I expect to encounter?