Invalid linearize curve -- not constantly increasing


#1

I can’t create a .quad as instructed. my L values are in order and corrected. How can I correct the .txt file? I tried to open the Piezography error corrector but it doesn’t open in Safari. I have measured the 129 step twice with i1Pro2. Any suggestions?

jfammart


#2

Please attach the text file - otherwise we (speaking only for myself of course ;)) can only guess.


#3

Here what I got.

jfammart

PltPld-curve-2-out.txt (11.5 KB)


#4

Not the -out file. The one you used with the quad that you ran thru QTR-Linearize-Quad that created the -out file.


#5

Actually, it would be helpful to see your Smoother (Numbers) file too, and the quad if it is not one of the IJM quads. If it is, just tell us which one.

I have to go out for an hour or so, but if Walker hasn’t responded before I get back I’ll give it a shot then.


#6

sorry, I misunderstood.

PltPld-curve-2.txt (2.01 KB)


#7

here is the smoother file. I exported it as a Excel, but did it in Numbers.

129STEP_PIEZODN_CGATS_SMOOTHER.xlsx (33.5 KB)


#8

Here is the Numbers version.

129STEP_PIEZODN_CGATS_SMOOTHER.numbers (137 KB)


#9

The problem is that in both the Excel and Numbers files the Smoother is not smoothing! The result is that the text file that you created still has the raw values. By any chance did you not enable macros when you opened the data file? I know that Excel asks permission to enable macros every time I open Smoother (or any of the PiezoDN tools).

When I open Piezography>Tools>129STEP_PIEZODN_CGATS_SMOOTHER.xlsb in Excel I always get an option to Enable Macros.

[attachment file=30729]
You must select Enable Macros otherwise the Smoother doesn’t work. This might explain why Excel is failing, but I’m not sure about Numbers since it does not have that option.

Excel-Enable-Macros.png


#10

Keith

I redid the Excel and enabled macros, then copy and pasted the LAB from the CGATS page to Sublime text to make a .txt file. I didn’t get an error message and saved this file as a .txt. When I use this and the original curve used to print into QTR linearize, I don’t get anything; no .quad nor .txt_out.

I’m not sure why this is happening since the smoothing did work in Excel this time.

Any ideas now?

jfammart

129STEP_PIEZODN_CGATS_SMOOTHER.xlsb (94.3 KB)


#11

It works for me. Got both the -out.txt and -lin.quad as expected. There are a few ways to get the quad and text file into QTR-Linearize-Quad. Please tell me exactly how you are doing it.

 


#12

Wait! When you made the txt file from the CGATS sheet did you include the entire thing or just the values? It should be the entire thing from A1 to D137. Using just the values won’t work.


#13

What Keith says is correct. You need to select from A1 to D137 in the CGATS sheet.

These cells are pre-selected in the installed smoother xlsx tool btw. All one usually needs to do is Edit>Copy.

best

Walker