Epson 3800 not registering photo black and light cyan cartridges

I just converted an Epson 3800 to piezography. I filled the replacement cartridges with piezo pro inkset and removed the OEM chips from the original cartridges and placed them under the reset chips. All the other cartridges were recognized with the exception of photo black and light cyan. I have tried reseating the chips several times and reset the printer as well as jiggled the installed cartridges but keep getting the same error message. Any suggestions like cleaning the contacts or anything? Thanks.

Please look at the photo back and cyan control chips. Under each control chip is three prongs. Sometimes these prongs are embedded in the control chip molding and need to be tweezed out. Then the control chip needs to be taped down over its three solder points to make firmer contact with the OEM chip below.

Please let me know if there are missing prongs or if none of this work and I’ll send PK and C replacement ASAP!!


I tried your suggestion and got the light cyan cartridge to register. I’m still having an issue getting the photo black cartridge to register. I tried a different control chip from a new replacement cartridge and tried a new OEM chip as well but no luck. I have tried using tape over the solder joints. I managed to tweeze out the prongs but they seem to be sticking out shorter than another one I compared with. Maybe a replacement photo black control chip would help as well as any other suggestions.

Never mind. I got the photo black to finally register. I’m not sure what finally worked. I cleaned all the gold contacts several times with alcohol and pushed all the cartridges to the left as I read in your FAQ section. Thanks for the help! They all register now!

I’m so glad it’s working.