Big Sur, P600 and error 'Filter' failed

Hello all -
I have installed Big Sur on a new iMac. Installed QTR, then Print Tool, then Piezography, and then the usual sequence with printer: Downloaded and installed the Epson driver for my SureColor P 600, then installed the Piezograophy curves for P600-PiezoDN-Pro.

Any file that I print only prints to about a third of the way, then the printer pushes the rest of the sheet out, and I get an error message in Epson print queue that says “Stopped - ‘Filter’ failed, 1 page”

I looked up an references to the ‘Filter’ failed message, and followed recommendations to reinstall the latest Epson driver.

No success.

I hope this is not a Big Sur issue.
Would welcome any thoughts.
Thanks,
Pradip

Hi Pradip,

Sorry to hear you are having this strange problem. Have you tried resetting the printing system? From the Printers & Scanners section of System Preferences, right-click (or control-click) over the printer list in the left-hand column and select Reset printing system…. Be aware that this will wipe out everything in that list and along with them any custom paper sizes, presets, &c. that you may have created.

I was having the dreaded Filter Failed problem with one of my several printer drivers (the Piezography Beta Driver that has sadly been moth-balled for the last couple years) after first installing Big Sur a few months ago. I tried many variations and combinations of deleting and reinstalling everything about that driver and the printer I was using with, but nothing worked. What did finally work, in my case, was when I updated Big Sur from 11.2.1 to 11.2.2, however it was an unexpected benefit of the update wiping out my entire printing system and having to reinstall three printers and their associated drivers – Epson, QTR/Piezography/PiezoDN, and the Piezography Beta driver – from scratch for each of my three 3880s with different inksets.

Unfortunately, when I updated Big Sur from 11.2.2 to 11.2.3 in March the same thing happened again – my whole printing system was erased and I had had to reinstall everything once again. I spent some time on the phone with AppleCare, and was quickly bumped up to 2nd-level support, but the upshot of that conversation was that there was no way to know if it would happen again until the next update comes along. They claimed to be unaware of the issue, but I had also commented in a related thread on the QTR forum that very day, and while I was on the phone and screensharing with the level-2 guy someone else popped in on the QTR thread with the exact same issue I was having, so I guess it’s happened to at least two people.

From my own searching for answers about this I can say with some confidence that it’s not limited to any particular printer brand or operating system. Filter failed seems to be a very generalized, undefined, non-specific kind of problem that can happen to any printer on Mac or Windows. It’s not specific to Epson or Big Sur, but that doesn’t mean it wont happen again. I hope resetting the print system does the trick for you.

Cheers,
Keith

1 Like

Thanks for this Keith!
Have run the Reset, but problem persists. Am going through the entire setup to see what’s up. Will report back as soon as I have a solution.
Stay well!
Pradip

Hi Keith and all:
just an update. I have had no success. Thus far, I have done the following (summary), rebooting the system between each step, just to be sure (!):

  1. Printed with other files to check the file was not corrupt. Same result, ‘Filter’ failed.
  2. Printed with PS, using the installed ‘normal’ EPSON SC-P600 driver. Full file printed. No error message.
  3. Uninstalled QTR, Print Tool and Piezography, downloaded latest of all sets, again, just to be sure, and reinstalled. Then printed in non-calibration mode (with a curve), got error message. Tried in calibration mode, got error message.
  4. Created a new user, repeated step 3, same results.
  5. In new user: reset the printers, same results
    : Uninstalled QTR, Print Tool and Piezography, Removed folders in Library > Printers > EPSON, QTR, PPD and InstalledPrinter.plist, deleted all contents in Cache folder, emptied Trash. Installed latest driver from EPSON, Reinstalled QTR, Print Tool and Piezography. Same results as step 2 and 3 above.

So, I am stumped. For now.

Good news / Bad news…
Updated to Mac OS 11.3.1.
Created a new user
Reinstalled QTR, Print Tool, the printer.
Sent file to print, and it all printed, BUT, still received the error message in Epson print queue that says “Stopped - ‘Filter’ failed, 1 page”.
Logged into my normal user account, repeated above, and file only printed about a third of the way in, then got the error message.

Any thoughts anyone?
Thanks,
P

This should be tested with a small file. Is it a small file?

-W

Yes, small file. Just the ink purge TIF.

try updating the firmware, then maybe a hail mary / switch usb ports or something?

Hi – thanks for this. Did it. No success. The latest is this:
I revived an old Mac, which had Catalina v 10.15.5 installed. Connected the printers and presto, all worked well with no error message.
Then, I ran the updater to the latest version of Catalina, 10.15.7, and presto, the Filter fail message began to appear again. BUT, this time, it seems that the full file is printing. So for now, am proceeding with this annoying glitch. I hope to revert the entire system back to 10.15.5 when I have more time.

Hi Pradip,

I upgraded my MacBook Pro (15 inch 2018) from Catalina to Big Sur 11.6 and found a similar issue. However, so far, the prints are seemingly complete before the print queue dialog displays the “filter failed” message. But I have only been printing small prints. Installed printer is Quad1430 - HDK6 and is listed as Paused after the error message, requiring you to click Resume. Quadtone RIP is version 2.8.0. I will work with this some more, but as long as it can finish the print job I will let it go and see if the Monterey upgrade fixes it.

B

I think Walker had noted somewhere else that the “filter failed” message was due to a glitch with QTR, and he suggested installing version 2.7. Have not done this myself, but may be worth a try. I have found that I can just ignore the message and carry on. I am using QTR 2.8 with Big Sur 11.6. There is another problem that is more irksome: it seems that with each update from 11.3 to .4 to .5 to .6, I have lost all installs of QTR printers and settings and have had to reinstall from Piezography > Curves > … install command again.

Am printing to a P600 wit Pro inks, up to 13x17 UP OHP film sizes.

Same here regarding reinstalling the printers. Wonder if the problem has been reported to QTR?

I posted about this exact issue earlier in this thread. I first experienced this problem late last March when updating from 11.2.2 to 11.2.3. I posted about it on 3/24/21 as an aside on a thread about the “filter failed” issue started by Neil Williamson @nwilliamson on the QTR forum. There were a couple of replies indicating a similar experience. I was also on the phone with level 2 support at Apple at that time but their only suggestion was to see if it happened again on the next update.

At that time, it seemed that the entire printing system was lost, Epson drivers as well as QTR/Piezo and my Canon office printer. The Canon reinstalled itself, but I manually reinstalled Epson and QTR drivers. On subsequent updates, the same thing occurred, but I noticed that if I gave it a little time the Epson drivers reappeared when I turned the printers on, though the QTR drivers (and Piezo Beta driver) had to be reinstalled manually. Sadly, custom presets did not come back.

I recall something like this being routine some 20-ish years ago, and that there was a way to save and reinstall presets and other custom settings but I don’t remember how it was done. Maybe if Walker or someone else here remembers this it would be worth testing.

There has been little to no further discussion of this issue that I have seen since that thread last March and my earlier mention of it here, so it may be a rare thing. I’m sorry to hear that it is afflicting others here and that I have no better idea of a solution.

Keith

PS – Reverting from QTR 2.8 to 2.7.9 (or maybe it’s 2.7.10, I can’t remember) solved the filter failed thing for me too.

Just wanted to clarify. Were you able to run QTR 2.7.10 on MacOS 11.6 (Big Sur)?

Yes, but to be clear as possible, there are 2 kinds of “filter failed” that I have encountered: the more serious one in which it interferes with printing, and the nuisance one where printing works normally but the message still shows up in the printer queue (or completed jobs list?). I am talking about the latter being solved by reverting from QTR 2.8.0 to 2.7.9. I should note that I am using a 2013 MacPro running on Big Sur 11.6 at this point.


I’m not sure why but I never used 2.7.10. Maybe because it was intended for Catalina which I skipped over.

Hope that’s less muddy,
Keith